summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorsayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-02 00:56:38 +0000
committersayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-02 00:56:38 +0000
commit957920726a6a8bc62201320760d8808db6f9c215 (patch)
treeb4c4ef2e2161d7f7ffc787b9cd387863c9bd470c /gcc/configure.ac
parentc505cd0fb7235d64fe30274f586bcbf14e493daf (diff)
downloadgcc-957920726a6a8bc62201320760d8808db6f9c215.tar.gz
* configure.ac (HAVE_AS_IX86_DIFF_SECT_DELTA): New test to determine
whether the assembler supports taking the difference of symbols in different sections. On x86/Solaris, GAS does but Solaris as doesn't. * configure: Regenerate. * config.in: Regenerate. * config/i386/sol2-10.h (JUMP_TABLES_IN_TEXT_SECTION): Define if the assembler doesn't support taking the difference of symbols in different sections, i.e. we're using the native solaris assembler. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@118405 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index fca9fedaf07..b089f607a75 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2850,6 +2850,18 @@ foo: nop
[AC_DEFINE(HAVE_AS_IX86_FFREEP, 1,
[Define if your assembler supports the ffreep mnemonic.])])
+ gcc_GAS_CHECK_FEATURE([different section symbol subtraction],
+ gcc_cv_as_ix86_diff_sect_delta,,,
+ [.section .rodata
+.L1:
+ .long .L2-.L1
+ .long .L3-.L1
+ .text
+.L3: nop
+.L2: nop],,
+ [AC_DEFINE(HAVE_AS_IX86_DIFF_SECT_DELTA, 1,
+ [Define if your assembler supports the subtraction of symbols in different sections.])])
+
# This one is used unconditionally by i386.[ch]; it is to be defined
# to 1 if the feature is present, 0 otherwise.
gcc_GAS_CHECK_FEATURE([GOTOFF in data],