summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorechristo <echristo@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-09 23:56:57 +0000
committerechristo <echristo@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-09 23:56:57 +0000
commit84eba00904bb9ca4f3e23bb8268bbeffeedf1d7a (patch)
tree10154e12ba067e5cf04925eae7c4ecdf66094e92 /gcc/configure.ac
parentf1ada0dfb2e91f1724a3ebc380c0cc94b72892b8 (diff)
downloadgcc-84eba00904bb9ca4f3e23bb8268bbeffeedf1d7a.tar.gz
2006-11-09 Eric Christopher <echristo@apple.com>
PR bootstrap/26892 PR bootstrap/27814 PR other/28994 * configure.ac: Match powerpc*-*-darwin* for powerpc darwin checks. * config.gcc (powerpc64-*-darwin*): New target. * config.host: Ditto. * config/rs6000/darwin64.h: New file. * config/rs6000/x-darwin64: Ditto. * config/rs6000/host-ppc64-darwin.c: Ditto. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@118633 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 9d265b0cf9c..e26100efbcf 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -983,7 +983,7 @@ vax-*-*)
stage1_cflags="-J"
fi
;;
-powerpc-*-darwin*)
+powerpc*-*-darwin*)
# The spiffy cpp-precomp chokes on some legitimate constructs in GCC
# sources; use -no-cpp-precomp to get to GNU cpp.
# Apple's GCC has bugs in designated initializer handling, so disable
@@ -1366,7 +1366,7 @@ if test "$host_xm_file" != "$build_xm_file"; then
fi
case ${host} in
- powerpc-*-darwin*)
+ powerpc*-*-darwin*)
AC_CACHE_CHECK([whether mcontext_t fields have underscores],
gcc_cv_mcontext_underscores,
AC_COMPILE_IFELSE([