summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorgeoffk <geoffk@138bc75d-0d04-0410-961f-82ee72b054a4>2004-11-05 04:49:19 +0000
committergeoffk <geoffk@138bc75d-0d04-0410-961f-82ee72b054a4>2004-11-05 04:49:19 +0000
commit50e7e370529f5c08cc6c4611c4a4c512968178e6 (patch)
tree9c0488dfa9919d3ba6f1c976082a924834f13942 /gcc/configure.ac
parentcb8e0dc9c2658c36d1d6e7b49c3ebf9321339ffd (diff)
downloadgcc-50e7e370529f5c08cc6c4611c4a4c512968178e6.tar.gz
Index: ChangeLog
2004-11-04 Geoffrey Keating <geoffk@apple.com> * Makefile.def: Build fixincludes for the host, too. * Makefile.in: Regenerate. * configure.in (host_tools): Add fixincludes. * configure: Regenerate. Index: fixincludes/ChangeLog 2004-11-04 Geoffrey Keating <geoffk@apple.com> * configure.ac: Add code to determine noncanonical_target, local_prefix, gcc_version; process mkheaders.in to make mkheaders. * configure: Regenerate. * fixinc.in: Move here from gcc/; fix many cross-hosting bugs. * mkfixinc.sh: Move here from gcc/; update for changes to fixinc.in. * mkheaders.in: Move here from gcc/; remove some unnecessary macros; update for changes to fixinc.in. * Makefile.in: Add many new macros. (install): New target. (mkheaders): New target. (fixinc.sh): New target. (all): Add mkheaders and fixinc.sh. * README-fixinc: Move here from gcc/. Index: gcc/ChangeLog 2004-11-04 Geoffrey Keating <geoffk@apple.com> * Makefile.in (distclean): Don't delete nonexistent fixinc/ directory. (install-mkheaders): Install the version built for the host, not for the build machine. * configure.ac: Always run fixincludes. (all_outputs): Remove mkheaders. * configure: Regenerate. * fixinc.in: Move to fixincludes/. * mkfixinc.sh: Likewise. * mkheaders.in: Likewise. * README-fixinc: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@90117 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index e5be4eefcc5..e13798568f4 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1684,20 +1684,12 @@ then
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
if test "x$TARGET_SYSTEM_ROOT" = x; then
- STMP_FIXINC=stmp-install-fixinc
if [ "x$STMP_FIXPROTO" != x ] ; then
STMP_FIXPROTO=stmp-install-fixproto
fi
fi
fi
-# When bootstrapping from the toplevel, only run fixincludes during stage1
-if test -d ../prev-gcc
-then
- STMP_FIXINC=stmp-install-fixinc
- cp -R ../prev-gcc/include include
-fi
-
# Expand extra_headers to include complete path.
# This substitutes for lots of t-* files.
extra_headers_list=
@@ -3034,7 +3026,7 @@ all_languages=
all_boot_languages=
all_compilers=
all_stagestuff=
-all_outputs='Makefile gccbug mklibgcc mkheaders libada-mk'
+all_outputs='Makefile gccbug mklibgcc libada-mk'
# List of language makefile fragments.
all_lang_makefrags=
# List of language subdirectory makefiles. Deprecated.