summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-15 06:26:59 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-15 06:26:59 +0000
commitc81c13fbb2afca2bf70bae0d119449db5aa2e621 (patch)
tree94d2bc0b48e63617c3f931843f720650b6acac62 /gcc/configure.ac
parent6d2e04be6cee5771209d1d0a24887b8e278678b6 (diff)
downloadgcc-c81c13fbb2afca2bf70bae0d119449db5aa2e621.tar.gz
2006-06-15 Paolo Bonzini <bonzini@gnu.org>
* Makefile.tpl (POSTSTAGE1_HOST_EXPORTS): Export CFLAGS and LDFLAGS too. * Makefile.in: Regenerate. gcc: 2006-06-15 Paolo Bonzini <bonzini@gnu.org> * configure.ac (CFLAGS): Get them from the toplevel or from the configure invocation. * configure: Regenerate. * Makefile.in (CFLAGS): Substitute value provided by configure. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@114673 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 081c4a0fb80..7a490dd65ef 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -278,6 +278,14 @@ fi
AC_SUBST(NO_MINUS_C_MINUS_O)
AC_SUBST(OUTPUT_OPTION)
+# Remove the -O2: for historical reasons, unless bootstrapping we prefer
+# optimizations to be activated explicitly by the toplevel.
+case "$CC" in
+ */prev-gcc/xgcc*) ;;
+ *) CFLAGS=`echo $CFLAGS | sed "s/-O[[s0-9]]* *//" ` ;;
+esac
+AC_SUBST(CFLAGS)
+
# -------------------------
# Check C compiler features
# -------------------------