summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2013-05-16 15:09:31 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2013-05-16 15:09:31 +0000
commitbe5f9e46eb176b948cf8e14d2be717e1027a1d93 (patch)
tree58dd6ed692243aaa8c1c4c970c25746342075404 /gcc/configure.ac
parentf4b2c95ec5da39ce94e8827c9b3a106b95b06da9 (diff)
downloadgcc-be5f9e46eb176b948cf8e14d2be717e1027a1d93.tar.gz
* Makefile.in (LLINKER): New variable.
(mostlyclean): Remove link mutex. * configure.ac: Handle --enable-link-mutex. * lock-and-run.sh: New script. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@198977 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a6cdf245ea5..855affdf152 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4958,6 +4958,24 @@ else
fi
AC_SUBST(MAINT)dnl
+dnl Whether to prevent multiple front-ends from linking at the same time
+
+AC_MSG_CHECKING([whether to avoid linking multiple front-ends at once])
+ AC_ARG_ENABLE(link-mutex,
+[AS_HELP_STRING([--enable-link-mutex],
+ [avoid linking multiple front-ends at once to avoid thrashing
+ on the build machine])],
+ do_link_mutex=$enableval,
+ do_link_mutex=no)
+AC_MSG_RESULT($do_link_mutex)
+
+if test "$do_link_mutex" = "yes"; then
+ DO_LINK_MUTEX=true
+else
+ DO_LINK_MUTEX=false
+fi
+AC_SUBST(DO_LINK_MUTEX)
+
# --------------
# Language hooks
# --------------