summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authordaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-25 00:42:17 +0000
committerdaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-25 00:42:17 +0000
commitc024e802aabed355c7dfa84018baea17865574f8 (patch)
tree888c2f40b853fa60782335d405f0331a624b95a0 /gcc/configure.ac
parent0a8c3753c83208c1149ccc38f44284414b30fb36 (diff)
downloadgcc-c024e802aabed355c7dfa84018baea17865574f8.tar.gz
PR java/25816
* configure.ac (enable_tls): New enable option. (HAVE_AS_TLS): Don't do assembler check if enable_tls set. * configure: Regenerate. * doc/install.texi (--enable-tls): Document new option. (--disable-tls): Ditto. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@110199 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac25
1 files changed, 22 insertions, 3 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 876b1deac51..e536b0ae547 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -679,6 +679,17 @@ AC_ARG_ENABLE(threads,
--enable-threads=LIB use LIB thread package for target GCC],,
[enable_threads=''])
+AC_ARG_ENABLE(tls,
+[ --enable-tls enable or disable generation of tls code
+ overriding the assembler check for tls support],
+[
+ case $enable_tls in
+ yes | no) ;;
+ *) AC_MSG_ERROR(['$enable_tls' is an invalid value for --enable-tls.
+Valid choices are 'yes' and 'no'.]) ;;
+ esac
+], [enable_tls=''])
+
AC_ARG_ENABLE(objc-gc,
[ --enable-objc-gc enable the use of Boehm's garbage collector with
the GNU Objective-C runtime],
@@ -2531,13 +2542,21 @@ foo: .long 25
;;
changequote([,])dnl
esac
-if test -z "$tls_first_major"; then
+set_have_as_tls=no
+if test "x$enable_tls" = xno ; then
+ : # TLS explicitly disabled.
+elif test "x$enable_tls" = xyes ; then
+ set_have_as_tls=yes # TLS explicitly enabled.
+elif test -z "$tls_first_major"; then
: # If we don't have a check, assume no support.
else
gcc_GAS_CHECK_FEATURE(thread-local storage support, gcc_cv_as_tls,
[$tls_first_major,$tls_first_minor,0], [$tls_as_opt], [$conftest_s],,
- [AC_DEFINE(HAVE_AS_TLS, 1,
- [Define if your assembler supports thread-local storage.])])
+ [set_have_as_tls=yes])
+fi
+if test $set_have_as_tls = yes ; then
+ AC_DEFINE(HAVE_AS_TLS, 1,
+ [Define if your assembler supports thread-local storage.])
fi
# Target-specific assembler checks.