summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-21 10:57:51 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-21 10:57:51 +0000
commitf95617d7618ecccab1f59cfa0faa395faafc6b5f (patch)
tree5d4112b947545fb355a9d7e6557e93a8a9e98b23 /gcc/configure.ac
parentb8f73c521f9041209c16e992863613ba7fd1a6ff (diff)
downloadgcc-f95617d7618ecccab1f59cfa0faa395faafc6b5f.tar.gz
* configure.ac (gcc_cv_lto_plugin): Fix typo.
Allow -fuse-linker-plugin for non-default plugin linker. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@171215 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 2e83b2d46da..adca466fe8f 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3192,14 +3192,14 @@ fi
AC_MSG_CHECKING(linker plugin support)
gcc_cv_lto_plugin=0
if test -f liblto_plugin.la; then
- if test $in_tree_ld = yes -a x"$ORIGINAL_PLUGIN_LD_FOR_TARGET=" = x"$gcc_cv_ld"; then
+ if test $in_tree_ld = yes -a x"$ORIGINAL_PLUGIN_LD_FOR_TARGET" = x"$gcc_cv_ld"; then
if test "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -ge 21 -o "$gcc_cv_gld_major_version" -gt 2; then
gcc_cv_lto_plugin=2
elif test "$ld_is_gold" = yes -a "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -eq 20; then
gcc_cv_lto_plugin=1
fi
- elif echo "$ld_ver" | grep GNU > /dev/null; then
+ elif test x"$ORIGINAL_PLUGIN_LD_FOR_TARGET" = x"$gcc_cv_ld" && echo "$ld_ver" | grep GNU > /dev/null; then
# Require GNU ld or gold 2.21+ for plugin support by default.
if test "$ld_vers_major" -eq 2 -a "$ld_vers_minor" -ge 21; then
gcc_cv_lto_plugin=2
@@ -3207,6 +3207,10 @@ if test -f liblto_plugin.la; then
elif test "$ld_is_gold" = yes -a "$ld_vers_major" -eq 2 -a "$ld_vers_minor" -eq 20; then
gcc_cv_lto_plugin=1
fi
+ elif test x"$ORIGINAL_PLUGIN_LD_FOR_TARGET" != x"$gcc_cv_ld"; then
+ # Allow -fuse-linker-plugin if plugin linker differs from
+ # default/specified linker.
+ gcc_cv_lto_plugin=1
fi
fi
AC_DEFINE_UNQUOTED(HAVE_LTO_PLUGIN, $gcc_cv_lto_plugin,