summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-05 03:58:46 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-05 03:58:46 +0000
commite08c7853cd1e57b4f82ad9c609ba989a04a6bf58 (patch)
tree7f0a960205235546c7759d86602d1d8705291234 /gcc/configure.ac
parent2e746e59b1b2a9abdf5e9de5864d2b37ade8f38a (diff)
downloadgcc-e08c7853cd1e57b4f82ad9c609ba989a04a6bf58.tar.gz
PR target/14548
* config.host: Set the shell variable host_can_use_collect2. Set it to yes by default, and to no for alpha*-dec-*vms*, i[34567]86-*-mingw32*, and powerpc-*-beos*. * configure.ac: Set and substitute the shell variable collect2. Give an error if use_collect2 is yes and host_can_use_collect2 is no. * Makefile.in (COLLECT2): Rename from USE_COLLECT2. Change all uses. Initialize to @collect2@. (STAGESTUFF): Remove $(USE_COLLECT2). * config/alpha/x-vms (USE_COLLECT2): Don't set. * config/i386/t-mingw32 (USE_COLLECT2): Likewise. * config/rs6000/t-beos (USE_COLLECT2): Likewise. * config/pa/t-pa64: Remove commented out USE_COLLECT2. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@80422 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index f35812d42f2..742432b5390 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1656,6 +1656,13 @@ for file in ${extra_headers} ; do
extra_headers_list="${extra_headers_list} \$(srcdir)/config/${cpu_type}/${file}"
done
+# Define collect2 in Makefile.
+case $host_can_use_collect2 in
+ no) collect2= ;;
+ *) collect2='collect2$(exeext)' ;;
+esac
+AC_SUBST([collect2])
+
# Add a definition of USE_COLLECT2 if system wants one.
case $use_collect2 in
no) use_collect2= ;;
@@ -1663,6 +1670,11 @@ case $use_collect2 in
*)
host_xm_defines="${host_xm_defines} USE_COLLECT2"
xm_defines="${xm_defines} USE_COLLECT2"
+ case $host_can_use_collect2 in
+ no)
+ AC_MSG_ERROR([collect2 is required but cannot be built on this system])
+ ;;
+ esac
;;
esac