summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-03-24 22:08:39 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-03-24 22:08:39 +0000
commitc0c5068d37a55b542e0577841a1881dbf66b2a8b (patch)
treef57c21720c18cb974ff82e4d9ec3569cc33c6d09 /gcc/configure.ac
parent98e744693bb32e059f2525974f09b35f69b097e5 (diff)
downloadgcc-c0c5068d37a55b542e0577841a1881dbf66b2a8b.tar.gz
(gcc)
* configure.ac: Add --enable-werror-always (for top level bootstrap support). * configure: Regenerate. (top level) * configure.in (top level bootstrap support): Rework --enable-werror to set @stage2_werror_flag@. * configure: Regenerate. * Makefile.tpl (top level bootstrap support): Pass @stage2_werror_flag@ down to configure in stages 2 and 3. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@79935 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7a4f7905662..a4da3d26541 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -346,6 +346,15 @@ if test $ac_cv_prog_cc_w_old_style_definition = yes ; then
strict1_warn="${strict1_warn} -Wold-style-definition"
fi
+# Enable -Werror, period.
+AC_ARG_ENABLE(werror_always,
+[ --enable-werror-always enable -Werror always], [],
+[enable_werror_always=no])
+if test x${enable_werror_always} = xyes ; then
+ strict1_warn="${strict1_warn} -Werror"
+ WERROR=-Werror
+fi
+
# If the native compiler is GCC, we can enable warnings even in stage1.
# That's useful for people building cross-compilers, or just running a
# quick `make'.