summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2008-03-27 09:46:19 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2008-03-27 09:46:19 +0000
commitb9146087cb069e6e6ea76d63008a8fdb8feef476 (patch)
tree734204d9b6817a2ec9a938bd0eb3536db216b649 /gcc/configure.ac
parent4add9df0da7cb40e58443029b11efc55a1841dd8 (diff)
downloadgcc-b9146087cb069e6e6ea76d63008a8fdb8feef476.tar.gz
config:
2008-03-27 Paolo Bonzini <bonzini@gnu.org> * extensions.m4: New. gcc: 2008-03-27 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Replace custom __GNU_SOURCE test with AC_USE_SYSTEM_EXTENSIONS. Move it earlier. * aclocal.m4: Regenerate. * configure: Regenerate. * config.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@133635 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a0351bd40a6..10e6a9eca58 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -297,6 +297,7 @@ AC_SUBST(CFLAGS)
# Check C compiler features
# -------------------------
+AC_USE_SYSTEM_EXTENSIONS
AC_PROG_CPP
AC_C_INLINE
@@ -896,20 +897,6 @@ fi
# Checks for C headers
# --------------------
-AC_MSG_CHECKING(for GNU C library)
-AC_CACHE_VAL(gcc_cv_glibc,
-[AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[#include <features.h>]], [[
-#if ! (defined __GLIBC__ || defined __GNU_LIBRARY__)
-#error Not a GNU C library system
-#endif]])],
- [gcc_cv_glibc=yes],
- [gcc_cv_glibc=no])])
-AC_MSG_RESULT($gcc_cv_glibc)
-if test $gcc_cv_glibc = yes; then
- AC_DEFINE(_GNU_SOURCE, 1, [Always define this when using the GNU C Library])
-fi
-
# Need to reject headers which give warnings, so that the -Werror bootstrap
# works later. *sigh* This needs to come before all header checks.
AC_PROG_CPP_WERROR