summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2013-03-27 21:54:50 +0000
committerktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2013-03-27 21:54:50 +0000
commit8f3115a2a840e3e450584a30911b18572add1a89 (patch)
treeb427cd629e6eecab8c62e4b8f3588776b007c4a5 /gcc/configure.ac
parentb0b82c407665672e142eb5c9f2d676e777aa1796 (diff)
downloadgcc-8f3115a2a840e3e450584a30911b18572add1a89.tar.gz
* config.build: Add support for cygwin x64 target.
* config.gcc: Likewise. * config.host: Likewise. * configure.ac: Likewise * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@197171 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index e9ad74c642d..068c66ae9a3 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3624,7 +3624,7 @@ changequote([,])dnl
# wrappers to aid in interposing and redirecting operators new, delete,
# etc., as per n2800 #17.6.4.6 [replacement.functions]. Check if we
# are configuring for a version of Cygwin that exports the wrappers.
- if test x$host = x$target; then
+ if test x$host = x$target && test x$host_cpu = xi686; then
AC_CHECK_FUNC([__wrap__Znaj],[gcc_ac_cygwin_dll_wrappers=yes],[gcc_ac_cygwin_dll_wrappers=no])
else
# Can't check presence of libc functions during cross-compile, so