summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2013-09-25 16:10:35 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2013-09-25 16:10:35 +0000
commite7c8aa66d3b4b615a7a79c92c42307f0f8cd7a50 (patch)
tree27e3854605955818b8f1b558056611f92e1f80f9 /gcc/configure.ac
parentb8bd120bd21885d1054cb062e04d0ce48e0fe849 (diff)
downloadgcc-e7c8aa66d3b4b615a7a79c92c42307f0f8cd7a50.tar.gz
* Makefile.in (OUTPUT_OPTION): Define as "-o $@".
* configure.ac: Don't invoke AM_PROG_CC_C_O. (NO_MINUS_C_MINUS_O, OUTPUT_OPTION): Don't subst. * configure, config.in: Rebuild. gcc/ada * gcc-interface/Makefile.in (OUTPUT_OPTION): Define as "-o $@". git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@202896 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index dc8b38b9412..f216962e18f 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -278,19 +278,9 @@ rm -f a.out a.exe b.out
# Find the native compiler
AC_PROG_CC
-AM_PROG_CC_C_O
AC_PROG_CXX
ACX_PROG_GNAT([-I"$srcdir"/ada])
-# autoconf is lame and doesn't give us any substitution variable for this.
-if eval "test \"`echo '$ac_cv_prog_cc_'${ac_cc}_c_o`\" = no"; then
- NO_MINUS_C_MINUS_O=yes
-else
- OUTPUT_OPTION='-o $@'
-fi
-AC_SUBST(NO_MINUS_C_MINUS_O)
-AC_SUBST(OUTPUT_OPTION)
-
# Remove the -O2: for historical reasons, unless bootstrapping we prefer
# optimizations to be activated explicitly by the toplevel.
case "$CC" in