summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authortschwinge <tschwinge@138bc75d-0d04-0410-961f-82ee72b054a4>2015-09-23 14:52:50 +0000
committertschwinge <tschwinge@138bc75d-0d04-0410-961f-82ee72b054a4>2015-09-23 14:52:50 +0000
commitdaa8f58fd840e8d35f362306fb54e1963f4cbd0f (patch)
treee56994358815ca037270fe39c1df903fc8423e3f /gcc/configure.ac
parentdf67b98cfa2f5943ddc469380abf4f3821f0f6af (diff)
downloadgcc-daa8f58fd840e8d35f362306fb54e1963f4cbd0f.tar.gz
Fix --enable-offload-targets/-foffload handling, pt. 1
gcc/ * configure.ac (offload_targets, OFFLOAD_TARGETS): Separate offload targets by commas, not colons. * config.in: Regenerate. * configure: Likewise. * gcc.c (driver::maybe_putenv_COLLECT_LTO_WRAPPER): Due to that, instead of setting up the default offload targets here... (process_command): ..., do it here. libgomp/ * plugin/configfrag.ac (OFFLOAD_TARGETS): Clarify that offload targets are separated by commas. * config.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@228053 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a6e078a998a..9d1f6f18eba 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -941,11 +941,11 @@ for tgt in `echo $enable_offload_targets | sed 's/,/ /g'`; do
if test x"$offload_targets" = x; then
offload_targets=$tgt
else
- offload_targets="$offload_targets:$tgt"
+ offload_targets="$offload_targets,$tgt"
fi
done
AC_DEFINE_UNQUOTED(OFFLOAD_TARGETS, "$offload_targets",
- [Define to hold the list of target names suitable for offloading.])
+ [Define to offload targets, separated by commas.])
if test x"$offload_targets" != x; then
AC_DEFINE(ENABLE_OFFLOADING, 1,
[Define this to enable support for offloading.])