summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authoruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2013-03-21 09:31:52 +0000
committeruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2013-03-21 09:31:52 +0000
commit9e2820ab23ece243d5250f1ce98b59bbff2e44e4 (patch)
treef3f069c571a8f10f954b123113318bd57b393d38 /gcc/configure.ac
parent7392f17cf5c7bb675a48fc12985a79c7d740792d (diff)
downloadgcc-9e2820ab23ece243d5250f1ce98b59bbff2e44e4.tar.gz
PR bootstrap/56656
* configure.ac (HAVE_AS_IX86_INTERUNIT_MOVQ): New test. * configure: Regenerate. * config.in: Regenerate. * config/i386/i386.md (*movdf_internal): Use HAVE_AS_IX86_INTERUNIT_MOVQ to handle broken assemblers that require movd instead of movq mnemonic for interunit moves. (*movdi_internal): Ditto. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@196861 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index f783b61510d..53cea1d5f9e 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3723,6 +3723,14 @@ foo: nop
[AC_DEFINE(HAVE_AS_IX86_SAHF, 1,
[Define if your assembler supports the sahf mnemonic in 64bit mode.])])
+ gcc_GAS_CHECK_FEATURE([interunit movq mnemonic],
+ gcc_cv_as_ix86_interunit_movq,,,
+ [.code64
+ movq %mm0, %rax
+ movq %rax, %xmm0],,
+ [AC_DEFINE(HAVE_AS_IX86_INTERUNIT_MOVQ, 1,
+ [Define if your assembler supports interunit movq mnemonic.])])
+
gcc_GAS_CHECK_FEATURE([hle prefixes],
gcc_cv_as_ix86_hle,,,
[lock xacquire cmpxchg %esi, (%ecx)],,