summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorsayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-07-07 00:13:14 +0000
committersayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-07-07 00:13:14 +0000
commit97f2677a5732fae5d6d8a86a30ec586db9b5cc1d (patch)
tree184927de213b7f5deec32e4f23bb6484e24ec6ee /gcc/configure.ac
parentf7963f05e2787565d92ea00d80f7c7e4f57bdfcf (diff)
downloadgcc-97f2677a5732fae5d6d8a86a30ec586db9b5cc1d.tar.gz
PR target/27968
* configure.ac (HAVE_AS_IX86_FFREEP): On x86 targets check whether the configured assembler supports the x87's ffreep mnemonic. * configure: Regenerate. * config.in: Regenerate. * config/i386/i386.c (output_387_ffreep): New function. (output_fp_compare): Use output_387_ffreep to emit ffreep insns. (output_387_reg_move): Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@115237 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7b3a5d10e18..5841da9bc87 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1,7 +1,7 @@
# configure.ac for GCC
# Process this file with autoconf to generate a configuration script.
-# Copyright 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
+# Copyright 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006
# Free Software Foundation, Inc.
#This file is part of GCC.
@@ -2815,6 +2815,12 @@ foo: nop
[AC_DEFINE(HAVE_AS_IX86_CMOV_SUN_SYNTAX, 1,
[Define if your assembler supports the Sun syntax for cmov.])])
+ gcc_GAS_CHECK_FEATURE([ffreep mnemonic],
+ gcc_cv_as_ix86_ffreep,,,
+ [ffreep %st(1)],,
+ [AC_DEFINE(HAVE_AS_IX86_FFREEP, 1,
+ [Define if your assembler supports the ffreep mnemonic.])])
+
# This one is used unconditionally by i386.[ch]; it is to be defined
# to 1 if the feature is present, 0 otherwise.
gcc_GAS_CHECK_FEATURE([GOTOFF in data],