summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authoruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-14 21:03:59 +0000
committeruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-14 21:03:59 +0000
commit735630ef5d264e0535d02bec3af5fd54f3f79f7b (patch)
tree607098977428b569ac568220d0c2c564dc2232f5 /gcc/configure.ac
parent2b28c6810695d870de9d3039beb6e7ab9a6bbd05 (diff)
downloadgcc-735630ef5d264e0535d02bec3af5fd54f3f79f7b.tar.gz
* configure.ac (HAVE_AS_IX86_SAHF): On x86 targets check whether
the configured assembler supports the sahf mnemonic. * configure: Regenerate. * config.in: Regenerate. * config/i386/i386.md (x86_sahf_1): Depending on HAVE_AS_IX86_SAHF, emit "sahf" or ".byte\t0x9e" as asm template. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@122931 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 768cff05208..18134cae8fb 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2808,6 +2808,12 @@ foo: nop
[AC_DEFINE(HAVE_AS_IX86_FFREEP, 1,
[Define if your assembler supports the ffreep mnemonic.])])
+ gcc_GAS_CHECK_FEATURE([sahf mnemonic],
+ gcc_cv_as_ix86_sahf,,,
+ [sahf],,
+ [AC_DEFINE(HAVE_AS_IX86_SAHF, 1,
+ [Define if your assembler supports the sahf mnemonic.])])
+
gcc_GAS_CHECK_FEATURE([different section symbol subtraction],
gcc_cv_as_ix86_diff_sect_delta,,,
[.section .rodata