summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-03 19:23:06 +0000
committerschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-03 19:23:06 +0000
commit34fe62ca4d73fb5fbe446f5fe9be2ed292cdca03 (patch)
treeb2590f513b8ab63891cdd4b0963419a435e0a3f9 /gcc/configure.ac
parent7fcab166dc9b8291cd969fb9b569cbf589acd7ab (diff)
downloadgcc-34fe62ca4d73fb5fbe446f5fe9be2ed292cdca03.tar.gz
* configure.ac (HAVE_AS_REL16): Move test back to correct place.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@122511 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index e64d106e708..83e13dd18f6 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1,7 +1,7 @@
# configure.ac for GCC
# Process this file with autoconf to generate a configuration script.
-# Copyright 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006
+# Copyright 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007
# Free Software Foundation, Inc.
#This file is part of GCC.
@@ -2926,6 +2926,12 @@ LCF0:
addis 11,30,_GLOBAL_OFFSET_TABLE_-.LCF0@ha';;
esac
+ gcc_GAS_CHECK_FEATURE([rel16 relocs],
+ gcc_cv_as_powerpc_rel16, [2,17,0], -a32,
+ [$conftest_s],,
+ [AC_DEFINE(HAVE_AS_REL16, 1,
+ [Define if your assembler supports R_PPC_REL16 relocs.])])
+
case $target in
*-*-aix*) conftest_s=' .machine "pwr6"
.csect .text[[PR]]
@@ -2955,12 +2961,6 @@ LCF0:
[$conftest_s],,
[AC_DEFINE(HAVE_AS_DFP, 1,
[Define if your assembler supports DFP instructions.])])
-
- gcc_GAS_CHECK_FEATURE([rel16 relocs],
- gcc_cv_as_powerpc_rel16, [2,17,0], -a32,
- [$conftest_s],,
- [AC_DEFINE(HAVE_AS_REL16, 1,
- [Define if your assembler supports R_PPC_REL16 relocs.])])
;;
mips*-*-*)