summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-26 04:02:24 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-26 04:02:24 +0000
commitff5f1a520caa9c02aef28b938f8045a61331a6f1 (patch)
tree94844f8fe08bec0ae9421339a340782e1641513e /gcc/configure.ac
parent5ce5bb153c019b07c3b369e1fc1ed7daf3ae462f (diff)
downloadgcc-ff5f1a520caa9c02aef28b938f8045a61331a6f1.tar.gz
* config/i386/cygwin.asm: Include auto-host.h.
(cfi_startproc, cfi_endproc, cfi_adjust_cfa_offset, cfi_def_cfa_register, cfi_register, cfi_push, cfi_pop): New macros. (__chkstk, __alloca): Annotate for dwarf2 unwind info. Drop alignment code from the 64-bit path. Use gas local labels. * config/i386/i386.md (pro_epilogue_adjust_stack_<mode>_2): Macroize from _di_2. Remove the useless constant integer argument. (pro_epilogue_adjust_stack_<mode>_3): New. (allocate_stack_worker_probe_<mode>): Macroize from allocate_stack_worker_{32,64}. Use __chkstk_ms. Update all users. * config/i386/i386.c (ix86_expand_prologue): Use __chkstk_ms; use gen_pro_epilogue_adjust_stack_*_3 and annotate it. (__chkstk_ms): New function. * config/i386/t-cygming (LIB1ASMFUNCS): Add _chkstk_ms. * gcc/config/i386/t-interix: Likewise. * configure.ac (HAVE_GAS_CFI_DIRECTIVE): Export for target. (HAVE_GAS_CFI_PERSONALITY_DIRECTIVE): Likewise. (HAVE_GAS_CFI_SECTIONS_DIRECTIVE): Likewise. * configure, config.in: Rebuild. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@164628 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 6ada451f2fe..e9a86149d8e 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2388,11 +2388,13 @@ else
# no objdump, err on the side of caution
gcc_cv_as_cfi_advance_working=no
fi
+GCC_TARGET_TEMPLATE(HAVE_GAS_CFI_DIRECTIVE)
AC_DEFINE_UNQUOTED(HAVE_GAS_CFI_DIRECTIVE,
[`if test $gcc_cv_as_cfi_directive = yes \
&& test $gcc_cv_as_cfi_advance_working = yes; then echo 1; else echo 0; fi`],
[Define 0/1 if your assembler supports CFI directives.])
+GCC_TARGET_TEMPLATE(HAVE_GAS_CFI_PERSONALITY_DIRECTIVE)
gcc_GAS_CHECK_FEATURE([cfi personality directive],
gcc_cv_as_cfi_personality_directive, ,,
[ .text
@@ -2426,6 +2428,7 @@ gcc_GAS_CHECK_FEATURE([cfi sections directive],
gcc_cv_as_cfi_sections_directive=yes
;;
esac])
+GCC_TARGET_TEMPLATE(HAVE_GAS_CFI_SECTIONS_DIRECTIVE)
AC_DEFINE_UNQUOTED(HAVE_GAS_CFI_SECTIONS_DIRECTIVE,
[`if test $gcc_cv_as_cfi_sections_directive = yes;
then echo 1; else echo 0; fi`],