summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authordnovillo <dnovillo@138bc75d-0d04-0410-961f-82ee72b054a4>2011-09-15 21:00:03 +0000
committerdnovillo <dnovillo@138bc75d-0d04-0410-961f-82ee72b054a4>2011-09-15 21:00:03 +0000
commit224d9f3db5e292d8e700700b9429c01c63e2dbfb (patch)
tree701e6a3873944b6f2226d0e7a4c7b25e7c11f7fe /gcc/configure.ac
parenta771cff407f45e85c4ca5992d63966faafce7f8e (diff)
downloadgcc-224d9f3db5e292d8e700700b9429c01c63e2dbfb.tar.gz
* Makefile.in (SYSROOT_CFLAGS_FOR_TARGET): Define from
@SYSROOT_CFLAGS_FOR_TARGET@. * configure.ac (SYSROOT_CFLAGS_FOR_TARGET): Set from build-sysroot. * configure: Regenerate. (site.exp): Add definition of TEST_ALWAYS_FLAGS. Remove setting of GCC_UNDER_TEST. testsuite/ChangeLog * lib/g++.exp (g++_init): Add $TEST_ALWAYS_FLAGS to ALWAYS_CXXFLAGS, if defined. * lib/gfortran.exp (gfortran_init): Add $TEST_ALWAYS_FLAGS to ALWAYS_GFORTRANFLAGS, if defined. * lib/go.exp (go_target_compile): Add $TEST_ALWAYS_FLAGS to ALWAYS_GOCFLAGS, if defined. * lib/obj-c++.exp (obj-c++_init): Add $TEST_ALWAYS_FLAGS to ALWAYS_OBJCXXFLAGS, if defined. * lib/gcc.exp (gcc_target_compile): Add $TEST_ALWAYS_FLAGS to additional_flags, if defined. * lib/gnat.exp (gnat_target_compile): Likewise. * lib/objc.exp (objc_target_compile): Likewise. * lib/target-supports-dg.exp (dg-add-options): Handle TEST_ALWAYS_FLAGS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@178897 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 51ab3acd409..126cb196450 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -727,7 +727,12 @@ AC_SUBST(enable_shared)
AC_ARG_WITH(build-sysroot,
[AS_HELP_STRING([--with-build-sysroot=sysroot],
- [use sysroot as the system root during the build])])
+ [use sysroot as the system root during the build])],
+ [if test x"$withval" != x ; then
+ SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
+ fi],
+ [SYSROOT_CFLAGS_FOR_TARGET=])
+AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
AC_ARG_WITH(sysroot,
[AS_HELP_STRING([[--with-sysroot[=DIR]]],