summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorStefan Dösinger <stefan@codeweavers.com>2009-10-12 16:36:37 +0000
committerRichard Henderson <rth@gcc.gnu.org>2009-10-12 09:36:37 -0700
commitafd2c302c6f4377ed46d809744115e67d363d997 (patch)
tree458ae7e284b9bdd2f115c05aee9e40fdb0d47167 /gcc/configure.ac
parentea1b2f550d560f911ee70052713b7e5a17d44f33 (diff)
downloadgcc-afd2c302c6f4377ed46d809744115e67d363d997.tar.gz
i386.md (vswapmov): New.
2009-10-12 Stefan Dösinger <stefan@codeweavers.com> * config/i386/i386.md (vswapmov): New. * config/i386/i386.c (ix86_handle_fndecl_attribute): New. (ix86_function_ms_hook_prologue): New. (ix86_expand_prologue): Handle ms_hook_prologue attribute. * configure.ac: Test for swap suffix support in as. * configure: Rebuild. From-SVN: r152670
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7947d285629..dd3b7e890d2 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3047,6 +3047,12 @@ foo: nop
[AC_DEFINE(HAVE_AS_IX86_SAHF, 1,
[Define if your assembler supports the sahf mnemonic.])])
+ gcc_GAS_CHECK_FEATURE([swap suffix],
+ gcc_cv_as_ix86_swap,,,
+ [movl.s %esp, %ebp],,
+ [AC_DEFINE(HAVE_AS_IX86_SWAP, 1,
+ [Define if your assembler supports the swap suffix.])])
+
gcc_GAS_CHECK_FEATURE([different section symbol subtraction],
gcc_cv_as_ix86_diff_sect_delta,,,
[.section .rodata