summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorEric Botcazou <ebotcazou@libertysurf.fr>2006-02-07 19:53:20 +0100
committerEric Botcazou <ebotcazou@gcc.gnu.org>2006-02-07 18:53:20 +0000
commit7935dc1bc3c1e806da0f6d2be8d9eae8dd0bdb08 (patch)
treee3f9f1ef194f4834a12be2f459429091624dcab0 /gcc/configure.ac
parent8fbe3bb2efdc6803b1509acd7224259cef455e52 (diff)
downloadgcc-7935dc1bc3c1e806da0f6d2be8d9eae8dd0bdb08.tar.gz
configure.ac (TLS assembler check): Do not enable TLS by default on SPARC/Solaris before version 10.
* configure.ac (TLS assembler check): Do not enable TLS by default on SPARC/Solaris before version 10. * configure: Regenerate. From-SVN: r110707
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index f8768915f4d..7d7655e7cc4 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2518,6 +2518,15 @@ foo: .long 25
;;
sparc*-*-*)
case "$target" in
+ sparc*-sun-solaris2.[56789]*)
+ # TLS was introduced in the Solaris 9 4/04 release but
+ # we do not enable it by default on Solaris 9 either.
+ if test "x$enable_tls" = xyes ; then
+ on_solaris=yes
+ else
+ enable_tls=no;
+ fi
+ ;;
sparc*-sun-solaris2.*)
on_solaris=yes
;;