summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorRichard Biener <rguenther@suse.de>2014-05-26 08:19:02 +0000
committerRichard Biener <rguenth@gcc.gnu.org>2014-05-26 08:19:02 +0000
commitedf6ddf6775b07472f2dbaeb3b9511fd2ab0e902 (patch)
treee28b8ab33b2de7eaa12479bdb8dfb1291a7f26d0 /gcc/configure.ac
parent49f002b654154f65320b984ac91ebe07d3891da3 (diff)
downloadgcc-edf6ddf6775b07472f2dbaeb3b9511fd2ab0e902.tar.gz
configure.ac: Remove long long and __int64 type checks...
2014-05-26 Richard Biener <rguenther@suse.de> libcpp/ * configure.ac: Remove long long and __int64 type checks, add check for uint64_t and fail if that wasn't found. * include/cpplib.h (cpp_num_part): Use uint64_t. * config.in: Regenerate. * configure: Likewise. gcc/ * configure.ac: Drop __int64 type check. Insist that we found uint64_t and int64_t. * hwint.h (HOST_BITS_PER___INT64): Remove. (HOST_BITS_PER_WIDE_INT): Define to 64 and remove __int64 case. (HOST_WIDE_INT_PRINT_*): Remove 32bit case. (HOST_WIDEST_INT*): Define to HOST_WIDE_INT*. (HOST_WIDEST_FAST_INT): Remove __int64 case. * vmsdbg.h (struct _DST_SRC_COMMAND): Use int64_t for dst_q_src_df_rms_cdt. * configure: Regenerate. * config.in: Likewise. From-SVN: r210928
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 281ce8e06a1..0f8566f9336 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -311,8 +311,10 @@ AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
AC_CHECK_TYPES([long long], [AC_CHECK_SIZEOF(long long)])
-AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
GCC_STDINT_TYPES
+if test x"$ac_cv_c_uint64_t" = x"no" -o x"$ac_cv_c_int64_t" = x"no"; then
+ AC_MSG_ERROR([uint64_t or int64_t not found])
+fi
# ---------------------
# Warnings and checking
@@ -1374,7 +1376,7 @@ fi
if test x$use_long_long_for_widest_fast_int = xyes; then
AC_DEFINE(USE_LONG_LONG_FOR_WIDEST_FAST_INT, 1,
-[Define to 1 if the 'long long' (or '__int64') is wider than 'long' but still
+[Define to 1 if the 'long long' type is wider than 'long' but still
efficiently supported by the host hardware.])
fi