summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hongjiu.lu@intel.com>2009-11-08 22:36:51 +0000
committerH.J. Lu <hjl@gcc.gnu.org>2009-11-08 14:36:51 -0800
commit5938f74ded1210131d04396065bb5cab7520a6a3 (patch)
treea77de50fab65df010cf9b254b0984429a0105147 /gcc/configure.ac
parentaeaebc93216fe846ebb66523caa1f50b170617b8 (diff)
downloadgcc-5938f74ded1210131d04396065bb5cab7520a6a3.tar.gz
collect2.c (main): Search PLUGIN_LD for plugin linker.
2009-11-08 H.J. Lu <hongjiu.lu@intel.com> * collect2.c (main): Search PLUGIN_LD for plugin linker. * configure.ac (--with-plugin-ld): New. Default to ld. * configure: Regenerated. * config.in: Likewise. * exec-tool.in (ORIGINAL_PLUGIN_LD_FOR_TARGET): New. (collect-ld): Use ORIGINAL_PLUGIN_LD_FOR_TARGET for -plugin. From-SVN: r154020
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index dd3b7e890d2..dfc72991c50 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1915,6 +1915,17 @@ else
AC_PATH_PROG(gcc_cv_ld, $LD_FOR_TARGET)
fi])
+ORIGINAL_PLUGIN_LD_FOR_TARGET=$gcc_cv_ld
+PLUGIN_LD=`basename $gcc_cv_ld`
+AC_ARG_WITH(plugin-ld,
+[ --with-plugin-ld=[[ARG]] specify the plugin linker],
+[if test x"$withval" != x; then
+ ORIGINAL_PLUGIN_LD_FOR_TARGET="$withval"
+ PLUGIN_LD="$withval"
+ fi])
+AC_SUBST(ORIGINAL_PLUGIN_LD_FOR_TARGET)
+AC_DEFINE_UNQUOTED(PLUGIN_LD, "$PLUGIN_LD", [Specify plugin linker])
+
ORIGINAL_LD_FOR_TARGET=$gcc_cv_ld
AC_SUBST(ORIGINAL_LD_FOR_TARGET)
case "$ORIGINAL_LD_FOR_TARGET" in