summaryrefslogtreecommitdiff
path: root/fastjar/configure.in
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2002-01-09 23:22:20 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2002-01-09 23:22:20 +0000
commit108cbb2a887bf0a30f17ccbf0d4e6ae6ac92ac69 (patch)
tree4ec2ce790b230d37a09abdcb0794c0003dd70c6b /fastjar/configure.in
parentb93f38e1aa4cde7539445e2931f6ba3752228e56 (diff)
downloadgcc-108cbb2a887bf0a30f17ccbf0d4e6ae6ac92ac69.tar.gz
For PR libgcj/5303:
* jargrep.h: Removed RCS keywords. (GVERSION): Removed. * configure, Makefile.in, config.h.in: Rebuilt. * configure.in: Added AM_MAINTAINER_MODE. Don't look for getopt.h. Use `fastjar' as package name. * Makefile.am (INCLUDES): Look in ../include. (LIBIBERTY): New macro. (jar_LDADD): Use it. (jar_DEPENDENCIES): Likewise. (grepjar_LDADD): Likewise. (grepjar_DEPENDENCIES): Likewise. * jargrep.c: Removed RCS keywords. Always include getopt.h. (LONG_OPT): New macro. (OPT_HELP): Likewise. (main): Use getopt_long. Let getopt print invalid argument message. Handle --help. Use version(). (version): New function. (optarg, optind): Don't declare. (option_vec): New global. (help): New function. (Usage): Updated to GNU standards. * jartool.c: Removed RCS keywords. Include getopt.h. (LONG_OPT): New macro. (OPT_HELP): Likewise. (options): New global. (help): New function. (usage): Print a single line. (version): New function. (expand_options): New function. (main): Use getopt_long and expand_options. Fail if `-u' specified. Changed handling of -f, -m, -V options. (OPTION_STRING): New macro. (version_string): Removed. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@48697 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'fastjar/configure.in')
-rw-r--r--fastjar/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/fastjar/configure.in b/fastjar/configure.in
index 5b98acf78bc..a3e8e90971c 100644
--- a/fastjar/configure.in
+++ b/fastjar/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(jartool.h)
-AM_INIT_AUTOMAKE(fastar, 0.92-gcc)
+AM_INIT_AUTOMAKE(fastjar, 0.92-gcc)
AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
@@ -12,6 +12,8 @@ AC_PATH_PROG(STRIP, strip, /usr/bin/strip, $PATH:/bin:/usr/bin:/usr/local/bin)
AC_PATH_PROG(CHMOD, chmod, /bin/chmod, $PATH:/bin:/usr/bin:/usr/local/bin)
AC_EXEEXT
+AM_MAINTAINER_MODE
+
dnl Add warning flags if we are using gcc.
if test "$GCC" = yes; then
fastjar_warn_cflags='-W -Wall -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings'
@@ -22,7 +24,7 @@ dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_STRUCT_TM
-AC_CHECK_HEADERS(fcntl.h unistd.h sys/param.h getopt.h stdlib.h)
+AC_CHECK_HEADERS(fcntl.h unistd.h sys/param.h stdlib.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_OFF_T