summaryrefslogtreecommitdiff
path: root/fastjar/Makefile.am
diff options
context:
space:
mode:
authorkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-12 20:29:49 +0000
committerkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-12 20:29:49 +0000
commit26b2607c247c694960db8c54ca04f12aceb131e3 (patch)
tree8ce709af92968f901a527a9109d6d20087c85f30 /fastjar/Makefile.am
parent90fc95ee14700fe745c1e247738d8f8497230565 (diff)
downloadgcc-26b2607c247c694960db8c54ca04f12aceb131e3.tar.gz
2004-04-12 Kelley Cook <kcook@gcc.gnu.org>
PR bootstrap/14905 * configure.ac: Parse --enable-generated-files-in-srcdir. * Makefile.am: Copy man and info files to srcdir if requested. * configure: Regenerate. * Makefile.in Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@80628 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'fastjar/Makefile.am')
-rw-r--r--fastjar/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/fastjar/Makefile.am b/fastjar/Makefile.am
index 3d4ea36c232..6c442e22868 100644
--- a/fastjar/Makefile.am
+++ b/fastjar/Makefile.am
@@ -82,3 +82,27 @@ jar.pod: $(srcdir)/fastjar.texi
grepjar.pod: $(srcdir)/fastjar.texi
-$(TEXI2POD) -D grepjar $< > $@
+
+# GCC LOCAL CHANGE
+# The following commands allow us to release tarballs with the man pages
+# and info documentation prebuilt. This feature is enabled via
+# --enable-generated-files-in-srcdir in the configure script.
+
+if GENINSRC
+STAMP_GENINSRC = stamp-geninsrc
+else
+STAMP_GENINSRC =
+endif
+
+all-local: $(STAMP_GENINSRC)
+
+stamp-geninsrc: jar.1 grepjar.1 fastjar.info
+ -cp -p $(top_builddir)/jar.1 $(srcdir)/jar.1
+ -cp -p $(top_builddir)/grepjar.1 $(srcdir)/grepjar.1
+ -cp -p $(top_builddir)/fastjar.info $(srcdir)/fastjar.info
+ touch $@
+
+CLEANFILES = stamp-geninsrc
+MAINTAINERCLEANFILES = $(srcdir)/jar.1 \
+ $(srcdir)/grepjar.1 \
+ $(srcdir)/fastjar.info