summaryrefslogtreecommitdiff
path: root/fastjar/Makefile.am
diff options
context:
space:
mode:
authorapbianco <apbianco@138bc75d-0d04-0410-961f-82ee72b054a4>2000-12-09 03:08:23 +0000
committerapbianco <apbianco@138bc75d-0d04-0410-961f-82ee72b054a4>2000-12-09 03:08:23 +0000
commit7ce26751b948af5be89a7da5882b19703c48f7fe (patch)
tree87ea917f50267296afe6acf62ccf01cba566fa09 /fastjar/Makefile.am
parent68a758b6de03182f0683314be57cae52979cd6c5 (diff)
downloadgcc-7ce26751b948af5be89a7da5882b19703c48f7fe.tar.gz
2000-12-08 Alexandre Petit-Bianco <apbianco@cygnus.com>
* fastjar: Imported. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@38145 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'fastjar/Makefile.am')
-rw-r--r--fastjar/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/fastjar/Makefile.am b/fastjar/Makefile.am
new file mode 100644
index 00000000000..037b57225f9
--- /dev/null
+++ b/fastjar/Makefile.am
@@ -0,0 +1,50 @@
+# Process this with automake to create Makefile.in
+
+# Work around what appears to be a GNU make bug handling MAKEFLAGS
+# values defined in terms of make variables, as is the case for CC and
+# friends when we are called from the top level Makefile.
+AM_MAKEFLAGS = \
+ "AR_FLAGS=$(AR_FLAGS)" \
+ "CC_FOR_BUILD=$(CC_FOR_BUILD)" \
+ "CFLAGS=$(CFLAGS)" \
+ "CXXFLAGS=$(CXXFLAGS)" \
+ "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
+ "CFLAGS_FOR_TARGET=$(CFLAGS_FOR_TARGET)" \
+ "INSTALL=$(INSTALL)" \
+ "INSTALL_DATA=$(INSTALL_DATA)" \
+ "INSTALL_PROGRAM=$(INSTALL_PROGRAM)" \
+ "INSTALL_SCRIPT=$(INSTALL_SCRIPT)" \
+ "JC1FLAGS=$(JC1FLAGS)" \
+ "LDFLAGS=$(LDFLAGS)" \
+ "LIBCFLAGS=$(LIBCFLAGS)" \
+ "LIBCFLAGS_FOR_TARGET=$(LIBCFLAGS_FOR_TARGET)" \
+ "MAKE=$(MAKE)" \
+ "MAKEINFO=$(MAKEINFO) $(MAKEINFOFLAGS)" \
+ "PICFLAG=$(PICFLAG)" \
+ "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
+ "SHELL=$(SHELL)" \
+ "exec_prefix=$(exec_prefix)" \
+ "infodir=$(infodir)" \
+ "libdir=$(libdir)" \
+ "prefix=$(prefix)" \
+ "AR=$(AR)" \
+ "AS=$(AS)" \
+ "CC=$(CC)" \
+ "CXX=$(CXX)" \
+ "LD=$(LD)" \
+ "LIBCFLAGS=$(LIBCFLAGS)" \
+ "NM=$(NM)" \
+ "PICFLAG=$(PICFLAG)" \
+ "RANLIB=$(RANLIB)" \
+ "DESTDIR=$(DESTDIR)"
+
+INCLUDES = -I. -I$(top_srcdir) $(ZINCS)
+
+bin_PROGRAMS = fastjar grepjar
+fastjar_SOURCES = jartool.c dostime.c compress.c pushback.c jartool.h zipfile.h dostime.h compress.h pushback.h
+fastjar_LDADD = $(ZLIBS)
+fastjar_DEPENDENCIES = $(ZDEPS)
+grepjar_SOURCES = jargrep.c dostime.c compress.c pushback.c jartool.h zipfile.h dostime.h compress.h pushback.h
+grepjar_LDADD = $(ZLIBS)
+grepjar_DEPENDENCIES = $(ZDEPS)
+