summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordrow <drow@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-05 19:29:29 +0000
committerdrow <drow@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-05 19:29:29 +0000
commit0a2e6193ad3098fccc923067d56b14ed88359f31 (patch)
tree724d051a34214e4639ce4814ee0d33d1a05e31a1 /configure.in
parent6b68e71ad8f9dc3c16f8a8b41929909bf4b7fd54 (diff)
downloadgcc-0a2e6193ad3098fccc923067d56b14ed88359f31.tar.gz
* Makefile.tpl (all-target): Correct @if conditional for target
modules. * configure.in: Omit libiberty if building only target libgcc. * configure, Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@120494 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a80846703ce..4da1a186155 100644
--- a/configure.in
+++ b/configure.in
@@ -1439,10 +1439,14 @@ done
# Sometimes the tools are distributed with libiberty but with no other
# libraries. In that case, we don't want to build target-libiberty.
+# Don't let libgcc imply libiberty either.
if test -n "${target_configdirs}" ; then
+ libgcc=
others=
for i in `echo ${target_configdirs} | sed -e s/target-//g` ; do
- if test "$i" != "libiberty" ; then
+ if test "$i" = "libgcc"; then
+ libgcc=target-libgcc
+ elif test "$i" != "libiberty" ; then
if test -r $srcdir/$i/configure ; then
others=yes;
break;
@@ -1450,7 +1454,7 @@ if test -n "${target_configdirs}" ; then
fi
done
if test -z "${others}" ; then
- target_configdirs=
+ target_configdirs=$libgcc
fi
fi