summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2001-04-25 21:29:48 +0000
committerAlexandre Oliva <aoliva@gcc.gnu.org>2001-04-25 21:29:48 +0000
commit8343765d386e279eea553dbdfcd4db1f3b52058b (patch)
treeb7409db7c0637db1cbc00703684ba536b3054bdd /configure.in
parentb5cd6849d1c40c64411e1afc2bad31c865ba315a (diff)
downloadgcc-8343765d386e279eea553dbdfcd4db1f3b52058b.tar.gz
configure.in (libgcj_saved): Copy from $libgcj.
* configure.in (libgcj_saved): Copy from $libgcj. (libgcj): Zero out if --enable-libgcj; add to noconfigdirs is --disable-libgcj. From-SVN: r41551
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d9f2bb15c4a..056d7d22489 100644
--- a/configure.in
+++ b/configure.in
@@ -585,6 +585,22 @@ case "${host}" in
;;
esac
+# Save it here so that, even in case of --enable-libgcj, if the Java
+# front-end isn't enabled, we still get libgcj disabled.
+libgcj_saved=$libgcj
+case $enable_libgcj in
+yes)
+ # If we reset it here, it won't get added to noconfigdirs in the
+ # target-specific build rules, so it will be forcibly enabled
+ # (unless the Java language itself isn't enabled).
+ libgcj=
+ ;;
+no)
+ # Make sure we get it printed in the list of not supported target libs.
+ noconfigdirs="$noconfigdirs ${libgcj}"
+ ;;
+esac
+
case "${target}" in
*-*-chorusos)
noconfigdirs="$noconfigdirs target-newlib target-libgloss ${libgcj}"