summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-18 14:08:54 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-18 14:08:54 +0000
commit2a9efd1a06876cd9a54e0d485e5f5b9ee2bebefa (patch)
treea8d100a539625b15ad5f4715424b31f458b71297 /configure.in
parentcd7eb59267f9183e405e71e35f34a0e6b570a535 (diff)
downloadgcc-2a9efd1a06876cd9a54e0d485e5f5b9ee2bebefa.tar.gz
* configure.in (--with-mpfr-dir): Also look in .libs and _libs for
libmpfr.a. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@118972 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ccb1b93ecdf..1f5e3bd9c86 100644
--- a/configure.in
+++ b/configure.in
@@ -1058,7 +1058,13 @@ AC_ARG_WITH(mpfr-dir, [ --with-mpfr-dir=PATH Specify source directory for MP
if test "x$with_mpfr_dir" != x; then
gmpinc="-I$with_mpfr_dir"
- gmplibs="$with_mpfr_dir/libmpfr.a"
+ if test -f "$with_mpfr_dir/.libs/libmpfr.a"; then
+ gmplibs="$with_mpfr_dir/.libs/libmpfr.a"
+ elif test -f "$with_mpfr_dir/_libs/libmpfr.a"; then
+ gmplibs="$with_mpfr_dir/_libs/libmpfr.a"
+ else
+ gmplibs="$with_mpfr_dir/libmpfr.a"
+ fi
else
gmplibs="-lmpfr"
fi