summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-12-29 15:06:55 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-12-29 15:06:55 +0000
commit0157cc75c1dd79684c9902d9652482711eb52149 (patch)
treebc948e39f4208ab26f88d749854880365f5df011 /configure.in
parent7d9abd15f0a11d1ef4a06f6f3d1355f4ea442d2f (diff)
downloadgcc-0157cc75c1dd79684c9902d9652482711eb52149.tar.gz
* configure.in: Warn that MPFR 2.2.0 is buggy.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@120262 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d307bcf810e..e8face10ac9 100644
--- a/configure.in
+++ b/configure.in
@@ -1117,14 +1117,22 @@ choke me
if test x"$have_gmp" = xyes; then
saved_LIBS="$LIBS"
LIBS="$LIBS $gmplibs"
+ dnl MPFR 2.2.0 is acceptable but buggy, MPFR 2.2.1 is better.
AC_MSG_CHECKING([for correct version of mpfr.h])
AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
-#if MPFR_VERSION_MAJOR < 2 || (MPFR_VERSION_MAJOR == 2 && MPFR_VERSION_MINOR < 2)
+#if MPFR_VERSION < MPFR_VERSION_NUM(2,2,0)
choke me
#endif
mpfr_t n; mpfr_init(n);
-], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); have_gmp=no])
+], [AC_TRY_LINK([#include <gmp.h>
+#include <mpfr.h>],[
+#if MPFR_VERSION < MPFR_VERSION_NUM(2,2,1)
+ choke me
+#endif
+ mpfr_t n; mpfr_init(n);
+], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])])],
+ [AC_MSG_RESULT([no]); have_gmp=no])
LIBS="$saved_LIBS"
fi
CFLAGS="$saved_CFLAGS"