summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Meissner <meissner@cygnus.com>1998-04-22 12:33:17 +0000
committerMichael Meissner <meissner@gcc.gnu.org>1998-04-22 12:33:17 +0000
commit3f4ea1dee8bf07bf77f7b7417fe77652be421afc (patch)
tree6e5f919323ba6d54edf6aab99c927df6b57a25b5 /configure.in
parentdb4c1c35224b08236e25739bf656f569cd4d172f (diff)
downloadgcc-3f4ea1dee8bf07bf77f7b7417fe77652be421afc.tar.gz
Add support for --enable-target-optspace to compile with -Os instead of -O2, and default m32r to use it
From-SVN: r19374
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 21c0b4b6e70..f66ce6f6842 100644
--- a/configure.in
+++ b/configure.in
@@ -311,6 +311,24 @@ case "${target}" in
;;
esac
+# If --enable-target-optspace always use -Os instead of -O2 to build
+# the target libraries, similarly if it is not specified, use -Os
+# on selected platforms.
+echo "---${enable_target_optspace}:${target}--" 1>&2
+case "${enable_target_optspace}:${target}" in
+ yes:*)
+ target_makefile_frag="${target_makefile_frag} config/mt-ospace"
+ ;;
+ :m32r-*)
+ target_makefile_frag="${target_makefile_frag} config/mt-ospace"
+ ;;
+ no:* | :*)
+ ;;
+ *)
+ echo "*** bad value \"${enable_target_optspace}\" for --enable-target-optspace flag; ignored" 1>&2
+ ;;
+esac
+
skipdirs=
gasdir=gas
use_gnu_ld=