summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Wilson <wilson@cygnus.com>1997-09-01 23:55:29 +0000
committerJim Wilson <wilson@gcc.gnu.org>1997-09-01 16:55:29 -0700
commit558a1e7cb3bd7c401f3152d1cd18c7d92afc157a (patch)
treec7e36cee69673b7c0c721c97e287e02b218fbba8 /configure.in
parentbc4ddc77a0384a256abbc001a2cb612426d55ca5 (diff)
downloadgcc-558a1e7cb3bd7c401f3152d1cd18c7d92afc157a.tar.gz
Fix sunos4/rs6000/powerpc/etc build problems with multilibbed libraries.
* configure.in (target_subdir): Set to libraries if enable_multilib. From-SVN: r15025
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e251e85b424..70d8a87ec51 100644
--- a/configure.in
+++ b/configure.in
@@ -244,12 +244,12 @@ if [ x"${host}" = x"${target}" ] ; then
# that are in the 'cross only' list
skipdirs="${skipdirs} ${cross_only}"
is_cross_compiler=no
- target_subdir=.
- case "${host}" in
- # We need multilib support for irix6, to get libiberty built
- # properly for o32 and n32.
- mips-sgi-irix6*) target_subdir=${host} ;;
- esac
+ # Default to --enable-multilib. See similar code below.
+ if [ x${enable_multilib} = xno ]; then
+ target_subdir=.
+ else
+ target_subdir=libraries
+ fi
else
# similarly, don't build the targets in the 'native only'
# list when building a cross compiler