summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormmitchel <mmitchel@138bc75d-0d04-0410-961f-82ee72b054a4>2005-07-26 15:56:56 +0000
committermmitchel <mmitchel@138bc75d-0d04-0410-961f-82ee72b054a4>2005-07-26 15:56:56 +0000
commitffa8502d477ea4a4348fb5fffb7dd52d7d8305df (patch)
tree0284f0554e4dd176bea11df5e10b97ef13c79945 /configure.in
parent9f3b67fe3cdb302d35aa0c865805213a3529a104 (diff)
downloadgcc-ffa8502d477ea4a4348fb5fffb7dd52d7d8305df.tar.gz
* doc/install.texi (--with-build-sysroot): Fix grammatical error.
Clarify use of "build" in name. * Makefile.tpl (SYSROOT_CFLAGS_FOR_TARGET): New variable. (CFLAGS_FOR_TARGET): Use it. (CXXFLAGS_FOR_TARGET): Likewise. * Makefile.in: Regenerated. * configure.in (--with-build-sysroot): New option. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@102389 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d7c006c129a..f5877a708a4 100644
--- a/configure.in
+++ b/configure.in
@@ -1405,6 +1405,15 @@ esac
copy_dirs=
+AC_ARG_WITH([build-sysroot],
+ [ --with-build-sysroot=sysroot
+ use sysroot as the system root during the build],
+ [if test x"$withval" != x ; then
+ SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
+ fi],
+ [SYSROOT_CFLAGS_FOR_TARGET=])
+AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then