summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorebotcazou <ebotcazou@138bc75d-0d04-0410-961f-82ee72b054a4>2006-07-04 07:52:47 +0000
committerebotcazou <ebotcazou@138bc75d-0d04-0410-961f-82ee72b054a4>2006-07-04 07:52:47 +0000
commitf508ba97e0627d0439bab5da7c5c0505de738303 (patch)
treec3b9e31f432f73e77358b1d33eac3ed3d9d9a590 /configure.in
parent487b16e9f411cc40cb590a45a65c5ff667c37fa7 (diff)
downloadgcc-f508ba97e0627d0439bab5da7c5c0505de738303.tar.gz
PR bootstrap/18058
* configure.in: Add -fkeep-inline-functions to CFLAGS for stage 1 if the bootstrap compiler is a GCC version that supports it. * configure: Regenerate. gcc/ * Makefile.in (BUILD_RTL): Add build/vec.o. (build/gencondmd.o): Filter out -fkeep-inline-functions. (build/genextract): Delete. (build/genautomata): Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@115172 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dd5d21df275..a67a0a2bc90 100644
--- a/configure.in
+++ b/configure.in
@@ -2411,6 +2411,21 @@ case $build in
stage1_cflags="-g -no-cpp-precomp -DHAVE_DESIGNATED_INITIALIZERS=0"
;;
esac
+
+# This is aimed to mimic bootstrap with a non-GCC compiler to catch problems.
+if test "$GCC" = yes; then
+ saved_CFLAGS="$CFLAGS"
+
+ # Pass -fkeep-inline-functions for stage 1 if the GCC version supports it.
+ CFLAGS="$CFLAGS -fkeep-inline-functions"
+ AC_MSG_CHECKING([whether -fkeep-inline-functions is supported])
+ AC_TRY_COMPILE(,,
+ [AC_MSG_RESULT([yes]); stage1_cflags="$stage1_cflags -fkeep-inline-functions"],
+ [AC_MSG_RESULT([no])])
+
+ CFLAGS="$saved_CFLAGS"
+fi
+
AC_SUBST(stage1_cflags)
# Enable -Werror in bootstrap stage2 and later.