summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-10-21 13:58:13 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-10-21 13:58:13 +0000
commit6a086156536dd7ba5021c4035537987dd0977f51 (patch)
treeb4d5cc7cf4a03f1acfaa9feddf666f1da921243a /configure.in
parentcc06222ab9d2b17dcd022fb903d71c9c7d776617 (diff)
downloadgcc-6a086156536dd7ba5021c4035537987dd0977f51.tar.gz
* configure.in: Require GMP-4.1+ and MPFR-2.2+. Don't check
need_gmp anymore. * configure: Regenerate. gcc: * Makefile.in (LIBS): Add $(GMPLIBS). * doc/install.texi: Update GMP and MPFR requirements. * doc/sourcebuild.texi (need_gmp): Delete. gcc/fortran: * Make-lang.in (F95_LIBS): Delete. * f951$(exeext): Use $(LIBS) instead of $(F95_LIBS). * config-lang.in (need_gmp): Delete. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@117933 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 9 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 2162f25de51..999495b037e 100644
--- a/configure.in
+++ b/configure.in
@@ -1103,24 +1103,24 @@ choke me
], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); have_gmp=no])
if test x"$have_gmp" = xyes; then
+ saved_LIBS="$LIBS"
+ LIBS="$LIBS $gmplibs"
AC_MSG_CHECKING([for correct version of mpfr.h])
- AC_TRY_COMPILE([#include "gmp.h"
+ AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
#if MPFR_VERSION_MAJOR < 2 || (MPFR_VERSION_MAJOR == 2 && MPFR_VERSION_MINOR < 2)
choke me
#endif
-], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy version of MPFR detected])])
-
- saved_LIBS="$LIBS"
- LIBS="$LIBS $gmplibs"
- AC_MSG_CHECKING([for any version of mpfr.h])
- AC_TRY_LINK([#include <gmp.h>
-#include <mpfr.h>], [mpfr_t n; mpfr_init(n);],
- [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); have_gmp=no])
+ mpfr_t n; mpfr_init(n);
+], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); have_gmp=no])
LIBS="$saved_LIBS"
fi
CFLAGS="$saved_CFLAGS"
+if test x$have_gmp != xyes; then
+ AC_MSG_ERROR([Building GCC requires GMP 4.1+ and MPFR 2.2+. Try the --with-gmp and/or --with-mpfr options.])
+fi
+
# Flags needed for both GMP and/or MPFR
AC_SUBST(gmplibs)
AC_SUBST(gmpinc)
@@ -1208,7 +1208,6 @@ if test -d ${srcdir}/gcc; then
subdir_requires=
boot_language=
build_by_default=
- need_gmp=
. ${lang_frag}
potential_languages="${potential_languages},${language}"
# This is quite sensitive to the ordering of the case statement arms.
@@ -1254,18 +1253,6 @@ if test -d ${srcdir}/gcc; then
esac
done
- # Disable languages that need GMP if it isn't available.
- case ,${enable_languages},:${have_gmp}:${need_gmp} in
- *,${language},*:no:yes)
- # Specifically requested language; tell them.
- AC_MSG_ERROR([GMP 4.1 and MPFR 2.2 or newer versions required by $language])
- ;;
- *:no:yes)
- # Silently disable.
- add_this_lang=no
- ;;
- esac
-
# Disable a language that is unsupported by the target.
case " $unsupported_languages " in
*" $language "*)