summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-01-03 18:23:22 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-01-03 18:23:22 +0000
commit74fef112ae691424eff1ee9f039f2d3bc0636639 (patch)
tree7ccd121723e06f4b1281c44aa379e039d885dc32 /configure.in
parent11c549895312c760b16957c265deb991e5d33f31 (diff)
downloadgcc-74fef112ae691424eff1ee9f039f2d3bc0636639.tar.gz
PR bootstrap/11932, PR bootstrap/11933
(I don't know if it will fix either of them, but it relates to them.) * configure.in: Don't use shared config.cache for target directories. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@75359 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d7b009cedc6..8c0826f8342 100644
--- a/configure.in
+++ b/configure.in
@@ -1850,8 +1850,17 @@ if test x${with_newlib} != xno && echo " ${target_configdirs} " | grep " newlib
target_configargs="--with-newlib ${target_configargs}"
fi
+# Different target subdirs use different values of certain variables
+# (notably CXX). Worse, multilibs use *lots* of different values.
+# Worse yet, autoconf 2.5x makes some of these 'precious', meaning that
+# it doesn't automatically accept command-line overrides of them.
+# This means it's not safe for target subdirs to share a cache file,
+# which is disgusting, but there you have it. Hopefully this can be
+# fixed in future. It's still worthwhile to use a cache file for each
+# directory. I think.
+
# Pass the appropriate --host, --build, and --cache-file arguments.
-target_configargs="--cache-file=../config.cache --host=${target_alias} --build=${build_alias} ${target_configargs}"
+target_configargs="--cache-file=config.cache --host=${target_alias} --build=${build_alias} ${target_configargs}"
# provide a proper gxx_include_dir.
# Note, if you change the default, make sure to fix both here and in