summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorcagney <cagney@138bc75d-0d04-0410-961f-82ee72b054a4>2003-01-06 17:37:24 +0000
committercagney <cagney@138bc75d-0d04-0410-961f-82ee72b054a4>2003-01-06 17:37:24 +0000
commit8fdaf281e068b8522e16ec2ca50f821a471d5580 (patch)
treeb55fd46347a23ef694b7dc02931d9583348a60d2 /configure.in
parent1efff400b24ea723542836ac1e0e7d9f3c51b861 (diff)
downloadgcc-8fdaf281e068b8522e16ec2ca50f821a471d5580.tar.gz
2003-01-06 Andrew Cagney <ac131313@redhat.com>
* configure.in (GDB_TK): Add tcl directories conditional on gdb/gdbtk directory being present. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@60943 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index edf913ecddb..7fc3b9ca5e2 100644
--- a/configure.in
+++ b/configure.in
@@ -1706,11 +1706,23 @@ done
# so we should be able to put the 'maybe's in unconditionally and
# leave out the maybe dependencies when enable_gdbtk is false. I'm not
# 100% sure that that's safe though.
+
+gdb_tk="maybe-all-tcl maybe-all-tk maybe-all-itcl maybe-all-tix maybe-all-libgui"
case "$enable_gdbtk" in
no)
GDB_TK="" ;;
+ yes)
+ GDB_TK="${gdb_tk}" ;;
*)
- GDB_TK="maybe-all-tcl maybe-all-tk maybe-all-itcl maybe-all-tix maybe-all-libgui" ;;
+ # Only add the dependency on gdbtk when GDBtk is part of the gdb
+ # distro. Eventually someone will fix this and move Insight, nee
+ # gdbtk to a separate directory.
+ if test -d ${srcdir}/gdb/gdbtk ; then
+ GDB_TK="${gdb_tk}"
+ else
+ GDB_TK=""
+ fi
+ ;;
esac
# Create the 'maybe dependencies'. This uses a temporary file.