summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormeissner <meissner@138bc75d-0d04-0410-961f-82ee72b054a4>1998-04-22 12:33:17 +0000
committermeissner <meissner@138bc75d-0d04-0410-961f-82ee72b054a4>1998-04-22 12:33:17 +0000
commit650ebf2fef63862bca691a6e0f578b54e8ccbf2f (patch)
tree6e5f919323ba6d54edf6aab99c927df6b57a25b5 /configure.in
parentd773717c433f3defc5b66e887b790764f6ef6795 (diff)
downloadgcc-650ebf2fef63862bca691a6e0f578b54e8ccbf2f.tar.gz
Add support for --enable-target-optspace to compile with -Os instead of -O2, and default m32r to use it
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@19374 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 21c0b4b6e70..f66ce6f6842 100644
--- a/configure.in
+++ b/configure.in
@@ -311,6 +311,24 @@ case "${target}" in
;;
esac
+# If --enable-target-optspace always use -Os instead of -O2 to build
+# the target libraries, similarly if it is not specified, use -Os
+# on selected platforms.
+echo "---${enable_target_optspace}:${target}--" 1>&2
+case "${enable_target_optspace}:${target}" in
+ yes:*)
+ target_makefile_frag="${target_makefile_frag} config/mt-ospace"
+ ;;
+ :m32r-*)
+ target_makefile_frag="${target_makefile_frag} config/mt-ospace"
+ ;;
+ no:* | :*)
+ ;;
+ *)
+ echo "*** bad value \"${enable_target_optspace}\" for --enable-target-optspace flag; ignored" 1>&2
+ ;;
+esac
+
skipdirs=
gasdir=gas
use_gnu_ld=