summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-18 01:26:21 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-18 01:26:21 +0000
commit49fbf4b925552657ef9fe53d8382dfc5d9723ac5 (patch)
tree50453d3a085029670f5bc4d0cbb0ea22590d6769 /configure.in
parentd9b3f26bfd2dcda4c60d6317ac42db8d348b398d (diff)
downloadgcc-49fbf4b925552657ef9fe53d8382dfc5d9723ac5.tar.gz
top:
* Makefile.def, Makefile.tpl, configure.in: Remove all mention of libf2c. * configure, Makefile.in: Regenerate. contrib: * gcc_update: Remove gcc/f/intdoc.texi and all libf2c files from list of files to be touched. * convert_to_f2c, convert_to_g2c, download_f2c: Delete. gcc: * f: Entire directory removed * c-common.h (CTI_G77_INTEGER_TYPE, CTI_G77_UINTEGER_TYPE) (CTI_G77_LONGINT_TYPE, CTI_G77_ULONGINT_TYPE) (g77_integer_type_node, g77_uinteger_type_node) (g77_longint_type_node, or g77_ulongint_type_node): Delete. * c-common.c (c_common_nodes_and_builtins): Do not initialize the above set of variables. * config/i386/uwin.h: No need to define WIN32_UWIN_TARGET. * doc/invoke.texi, doc/standards.texi: Remove cross-references to g77 manual. gcc/po: * exgettext (spec_error_string): Do not scan beyond the end of the string for a close brace. Do not bail out at the first incidence of %%e. * gcc.pot: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@81967 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index a3e1f863445..1b60f7d49db 100644
--- a/configure.in
+++ b/configure.in
@@ -150,7 +150,6 @@ target_libraries="target-libiberty \
target-newlib \
target-libstdc++-v3 \
target-libmudflap \
- target-libf2c \
target-libgfortran \
${libgcj} \
target-libobjc \
@@ -390,7 +389,7 @@ case "${target}" in
;;
*-*-kaos*)
# Remove unsupported stuff on all kaOS configurations.
- skipdirs="target-libiberty ${libgcj} target-libstdc++-v3 target-libf2c target-librx"
+ skipdirs="target-libiberty ${libgcj} target-libstdc++-v3 target-librx"
skipdirs="$skipdirs target-libobjc target-examples target-groff target-gperf"
skipdirs="$skipdirs zlib fastjar target-libjava target-boehm-gc target-zlib"
noconfigdirs="$noconfigdirs target-libgloss"
@@ -413,12 +412,6 @@ case "${target}" in
;;
*-*-rtems*)
noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
- case ${target} in
- h8300*-*-* | h8500-*-*)
- noconfigdirs="$noconfigdirs target-libf2c"
- ;;
- *) ;;
- esac
;;
*-*-uclinux*)
noconfigdirs="$noconfigdirs target-newlib target-libgloss target-rda ${libgcj}"
@@ -519,10 +512,10 @@ case "${target}" in
noconfigdirs="$noconfigdirs ${libgcj}"
;;
h8300*-*-*)
- noconfigdirs="$noconfigdirs target-libgloss ${libgcj} target-libf2c"
+ noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
;;
h8500-*-*)
- noconfigdirs="$noconfigdirs target-libstdc++-v3 target-libgloss ${libgcj} target-libf2c"
+ noconfigdirs="$noconfigdirs target-libstdc++-v3 target-libgloss ${libgcj}"
;;
hppa*64*-*-linux* | parisc*64*-*-linux*)
# In this case, it's because the hppa64-linux target is for