summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-01-15 23:39:59 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-01-15 23:39:59 +0000
commit99e98fcda3615b67111a7f4386a5d3370fd19130 (patch)
treec51dbeea9aee022e135b85ea3d294be6a579a555 /configure.in
parente6ef70f2d42c6087b6396c9a62f987ae85642a35 (diff)
downloadgcc-99e98fcda3615b67111a7f4386a5d3370fd19130.tar.gz
* configure.in: check whether host and target makefile
fragments exist before adding them to *_makefile_frag git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@17373 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 68d0d9dd58e..25db03d904b 100644
--- a/configure.in
+++ b/configure.in
@@ -278,7 +278,9 @@ if [ x${shared} = xyes ]; then
host_makefile_frag="${host_makefile_frag} config/mh-elfalphapic"
;;
*)
- host_makefile_frag="${host_makefile_frag} config/mh-${host_cpu}pic"
+ if test -f config/mh-${host_cpu}pic; then
+ host_makefile_frag="${host_makefile_frag} config/mh-${host_cpu}pic"
+ fi
;;
esac
fi
@@ -898,7 +900,9 @@ if [ x${shared} = xyes ]; then
target_makefile_frag="${target_makefile_frag} config/mt-elfalphapic"
;;
*)
- target_makefile_frag="${target_makefile_frag} config/mt-${target_cpu}pic"
+ if test -f config/mt-${target_cpu}pic; then
+ target_makefile_frag="${target_makefile_frag} config/mt-${target_cpu}pic"
+ fi
;;
esac
fi