summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2000-07-31 19:29:03 +0000
committeraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2000-07-31 19:29:03 +0000
commit4d3fd3b7b878b64fc889949ffc128c92688969fa (patch)
treecc086b1f789ce435252f70025ca59ad909d2f400 /configure.in
parentdd6a91babcc9b83142351d0fd7d6fef21ef79b5c (diff)
downloadgcc-4d3fd3b7b878b64fc889949ffc128c92688969fa.tar.gz
* configure.in (qCXX_FOR_TARGET): Quote `&' characters in
CXX_FOR_TARGET for sed. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@35390 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6a5a9bda155..2df5d1f306c 100644
--- a/configure.in
+++ b/configure.in
@@ -1314,6 +1314,7 @@ case $CXX_FOR_TARGET in
*' $(FLAGS_FOR_TARGET)') ;;
*) CXX_FOR_TARGET=$CXX_FOR_TARGET' $(FLAGS_FOR_TARGET)' ;;
esac
+qCXX_FOR_TARGET=`expr "x$CXX_FOR_TARGET" : 'x\(.*\)' | sed 's,&,\\\&,g'`
targargs="--cache-file=../config.cache --host=${target_alias} --build=${build_alias} ${targargs}"
sed -e "s:^TARGET_CONFIGDIRS[ ]*=.*$:TARGET_CONFIGDIRS = ${target_configdirs}:" \
@@ -1321,7 +1322,7 @@ sed -e "s:^TARGET_CONFIGDIRS[ ]*=.*$:TARGET_CONFIGDIRS = ${target_configdirs}:"
-e "s%^FLAGS_FOR_TARGET[ ]*=.*$%FLAGS_FOR_TARGET = ${FLAGS_FOR_TARGET}%" \
-e "s%^CC_FOR_TARGET[ ]*=.*$%CC_FOR_TARGET = ${CC_FOR_TARGET}%" \
-e "s%^CHILL_FOR_TARGET[ ]*=.*$%CHILL_FOR_TARGET = ${CHILL_FOR_TARGET}%" \
- -e "s%^CXX_FOR_TARGET[ ]*=.*$%CXX_FOR_TARGET = ${CXX_FOR_TARGET}%" \
+ -e "s%^CXX_FOR_TARGET[ ]*=.*$%CXX_FOR_TARGET = ${qCXX_FOR_TARGET}%" \
-e "s%^TARGET_SUBDIR[ ]*=.*$%TARGET_SUBDIR = ${target_subdir}%" \
-e "s%^gxx_include_dir[ ]*=.*$%gxx_include_dir=${gxx_include_dir}%" \
Makefile > Makefile.tem