summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>1997-09-01 23:55:29 +0000
committerwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>1997-09-01 23:55:29 +0000
commit0dcb4a65ea009f23e6606f9b1f5551f704b33f28 (patch)
treec7e36cee69673b7c0c721c97e287e02b218fbba8 /configure.in
parent6510de0556d2cbe0d0ba3804b21fcfb2b55096d1 (diff)
downloadgcc-0dcb4a65ea009f23e6606f9b1f5551f704b33f28.tar.gz
Fix sunos4/rs6000/powerpc/etc build problems with multilibbed libraries.
* configure.in (target_subdir): Set to libraries if enable_multilib. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@15025 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e251e85b424..70d8a87ec51 100644
--- a/configure.in
+++ b/configure.in
@@ -244,12 +244,12 @@ if [ x"${host}" = x"${target}" ] ; then
# that are in the 'cross only' list
skipdirs="${skipdirs} ${cross_only}"
is_cross_compiler=no
- target_subdir=.
- case "${host}" in
- # We need multilib support for irix6, to get libiberty built
- # properly for o32 and n32.
- mips-sgi-irix6*) target_subdir=${host} ;;
- esac
+ # Default to --enable-multilib. See similar code below.
+ if [ x${enable_multilib} = xno ]; then
+ target_subdir=.
+ else
+ target_subdir=libraries
+ fi
else
# similarly, don't build the targets in the 'native only'
# list when building a cross compiler