summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-02 18:34:24 +0000
committerschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-02 18:34:24 +0000
commit9c19a7461cdc52b9f320abdf7db980c3efdb16a5 (patch)
treec8ac67acca9e88b1a6a620a71db014d69adbedf1 /configure.in
parentdbf080159174614addc3bbedd0ce0d80b977f489 (diff)
downloadgcc-9c19a7461cdc52b9f320abdf7db980c3efdb16a5.tar.gz
* configure.in: When reconfiguring remove Makefile in
all stage directories. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@109240 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index ad7ec4d9a4d..c3ef95b9ec2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998,
-# 1999, 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# 1999, 2000, 2001, 2002, 2003, 2004, 2006 Free Software Foundation, Inc.
#
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -1802,10 +1802,13 @@ for module in ${build_configdirs} ; do
/^@endif build-$module-$bootstrap_suffix\$/d"
done
for module in ${configdirs} ; do
- if test -z "${no_recursion}" \
- && test -f ${module}/Makefile; then
- echo 1>&2 "*** removing ${module}/Makefile to force reconfigure"
- rm -f ${module}/Makefile
+ if test -z "${no_recursion}"; then
+ for file in stage*-${module}/Makefile ${module}/Makefile; do
+ if test -f ${file}; then
+ echo 1>&2 "*** removing ${file} to force reconfigure"
+ rm -f ${file}
+ fi
+ done
fi
extrasub="$extrasub
/^@if $module\$/d