summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2008-07-30 12:17:17 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2008-07-30 12:17:17 +0000
commit3bed0958a0f66633cb85949de0a4d6d275b57643 (patch)
treed34a32f40438fc8ddcd9451e3bd7aab5b01049ed /configure.ac
parentce4aa30e6b1efa4d44674a9e225e7f0b57c40d07 (diff)
downloadgcc-3bed0958a0f66633cb85949de0a4d6d275b57643.tar.gz
2008-07-30 Paolo Bonzini <bonzini@gnu.org>
* configure.ac: Add makefile fragments for hpux. * Makefile.def (flags_to_pass): Add ADA_CFLAGS. * Makefile.tpl (HOST_EXPORTS): Pass ADA_CFLAGS. * configure: Regenerate. * Makefile.in: Regenerate. config: 2008-07-30 Paolo Bonzini <bonzini@gnu.org> * mh-pa: New, from gcc/config/pa/x-ada. * mh-pa-hpux10: New, from gcc/config/pa/x-ada-hpux10. gcc: 2008-07-30 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Substitute ADA_CFLAGS. * configure: Regenerate. * config.host: Remove mention of pa/x-ada and pa/x-ada-hpux10 files. * Makefile.in: Remove mention of X_* variables. * config/pa/x-ada-hpux10: Remove. * config/pa/x-ada: Remove. * doc/fragments.texi: Update. gcc/ada: 2008-07-30 Paolo Bonzini <bonzini@gnu.org> * gcc-interface/Make-lang.in (ALL_ADAFLAGS): Remove X_ADAFLAGS and T_ADAFLAGS, replace ALL_ADA_CFLAGS with ADA_CFLAGS. (ALL_ADA_CFLAGS): Remove, replace throughout with ADA_CFLAGS. * gcc-interface/Makefile.in (XCFLAGS, X_CFLAGS, X_CPPFLAGS, T_CPPFLAGS, X_ADA_CFLAGS, T_ADA_CFLAGS, X_ADAFLAGS, T_ADAFLAGS, ADA_CFLAGS, ALL_ADA_CFLAGS): Remove. (ALL_ADAFLAGS, MOST_ADAFLAGS): Remove X_ADAFLAGS and T_ADAFLAGS, replace ALL_ADA_CFLAGS with ADA_CFLAGS. (GCC_CFLAGS): Remove X_CFLAGS. (LOOSE_CFLAGS): Remove X_CFLAGS and XCFLAGS. (ALL_CPPFLAGS): Remove X_CPPFLAGS and T_CPPFLAGS. (ADA_CFLAGS): Substitute. gnattools: 2008-07-30 Paolo Bonzini <bonzini@gnu.org> * configure.ac (x_ada_cflags): Remove. (ADA_CFLAGS): Substitute. * configure: Regenerate. * Makefile.in (ADA_CFLAGS): Substitute. (T_ADA_CFLAGS, X_ADA_CFLAGS, ALL_ADA_CFLAGS): Remove. (TOOLS_FLAGS_TO_PASS_1, TOOLS_FLAGS_TO_PASS_1re, TOOLS_FLAGS_TO_PASS_NATIVE, TOOLS_FLAGS_TO_PASS_CROSS): Pass ADA_CFLAGS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@138301 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b7fb222298d..dc9ffacf7c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1067,10 +1067,18 @@ case "${host}" in
# without overflowing the jump tables (-J says to use a 32 bit table)
tentative_cc="cc -J"
;;
- *-hp-hpux*)
+ hppa*-hp-hpux10*)
tentative_cc="cc -Wp,-H256000"
+ host_makefile_frag="config/mh-pa-hpux10"
;;
- *-*-hiux*)
+ hppa*-hp-hpux* | hppa*-*-hiux*)
+ tentative_cc="cc -Wp,-H256000"
+ host_makefile_frag="config/mh-pa"
+ ;;
+ hppa*-*)
+ host_makefile_frag="config/mh-pa"
+ ;;
+ *-hp-hpux* | *-*-hiux*)
tentative_cc="cc -Wp,-H256000"
;;
rs6000-*-lynxos*)