summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordnovillo <dnovillo@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-03 19:49:02 +0000
committerdnovillo <dnovillo@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-03 19:49:02 +0000
commit4ae8c98f346e631b735be15b09a41a1a043454d2 (patch)
tree12613bd0a74ebab231fdcc3df3d06933df60630e /configure.ac
parent1516b2fbc735e7e880e5b8d8cb68f549a669a420 (diff)
downloadgcc-4ae8c98f346e631b735be15b09a41a1a043454d2.tar.gz
2010-09-03 Jack Howarth <howarth@bromo.med.uc.edu>
* configure.ac: Enable LTO by default on Darwin. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@163839 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3d969aa0ebc..66df1d103b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1787,8 +1787,11 @@ to specify its location.])
AC_SUBST(libelflibs)
AC_SUBST(libelfinc)
fi],[if test x"$default_enable_lto" = x"yes" ; then
- # On non-ELF platforms, LTO must be explicitly enabled.
- enable_lto=no
+ case $target in
+ *-apple-darwin*) ;;
+ # On other non-ELF platforms, LTO must be explicitly enabled.
+ *) enable_lto=no ;;
+ esac
else
# Apart from ELF platforms, only Windows supports LTO so far. It
# would also be nice to check the binutils support, but we don't
@@ -1797,7 +1800,6 @@ fi],[if test x"$default_enable_lto" = x"yes" ; then
# -flto it won't be needed until after installation anyway.
case $target in
*-cygwin*|*-mingw*) ;;
- *-apple-darwin*) ;;
*) if test x"$enable_lto" = x"yes"; then
AC_MSG_ERROR([LTO support is not enabled for this target.])
fi