summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornickc <nickc@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-28 11:21:17 +0000
committernickc <nickc@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-28 11:21:17 +0000
commite3a1fe085df12cc5b64f7c99150260372847cfe4 (patch)
treecf1d308ae9d1f9c9c13b122ae5d0a007ffa7278e /configure.ac
parentdfc07fc4b3c6305a2516c6f6f9d9314fbc77065e (diff)
downloadgcc-e3a1fe085df12cc5b64f7c99150260372847cfe4.tar.gz
* configure.ac: Add support for *-*-dragonfly*
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@171600 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bac6486bcc3..34aad7598aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -349,7 +349,8 @@ case "${ENABLE_GOLD}" in
case "${target}" in
*-*-elf* | *-*-sysv4* | *-*-unixware* | *-*-eabi* | hppa*64*-*-hpux* \
| *-*-linux* | frv-*-uclinux* | *-*-irix5* | *-*-irix6* \
- | *-*-netbsd* | *-*-openbsd* | *-*-freebsd* | *-*-solaris2* | *-*-nto*)
+ | *-*-netbsd* | *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* \
+ | *-*-solaris2* | *-*-nto*)
case "${target}" in
*-*-linux*aout* | *-*-linux*oldld*)
;;
@@ -509,7 +510,7 @@ if test x$enable_libgomp = x ; then
case "${target}" in
*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu | *-*-kopensolaris*-gnu)
;;
- *-*-netbsd* | *-*-freebsd* | *-*-openbsd*)
+ *-*-netbsd* | *-*-freebsd* | *-*-openbsd* | *-*-dragonfly*)
;;
*-*-solaris2* | *-*-sysv4* | *-*-irix6* | *-*-osf* | *-*-hpux11*)
;;
@@ -545,6 +546,9 @@ case "${target}" in
noconfigdirs="$noconfigdirs sim target-rda"
noconfigdirs="$noconfigdirs ${libgcj}"
;;
+ *-*-dragonfly*)
+ noconfigdirs="$noconfigdirs target-newlib target-libgloss"
+ ;;
*-*-freebsd[[12]] | *-*-freebsd[[12]].* | *-*-freebsd*aout*)
noconfigdirs="$noconfigdirs target-newlib target-libgloss ${libgcj}"
;;