summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Edelsohn <dje.gcc@gmail.com>2012-11-13 14:19:14 +0000
committerDavid Edelsohn <dje@gcc.gnu.org>2012-11-13 09:19:14 -0500
commite7fae5500c8ebf2881ee028f0406148aea3dd7a0 (patch)
tree8d97fd357f0948d58c4c280f9038ea152732a2eb /configure.ac
parent3f2dc80614e12fe044bae48388f5f338b8e942b1 (diff)
downloadgcc-e7fae5500c8ebf2881ee028f0406148aea3dd7a0.tar.gz
configure.ac: Disable libsanitizer on AIX.
* configure.ac: Disable libsanitizer on AIX. Merge libquadmath sections. * configure: Regenerate. From-SVN: r193477
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c66aa748b44..1d958b4c203 100644
--- a/configure.ac
+++ b/configure.ac
@@ -540,6 +540,9 @@ fi
# Disable libquadmath for some systems.
case "${target}" in
+ avr-*-*)
+ noconfigdirs="$noconfigdirs target-libquadmath"
+ ;;
# libquadmath is unused on AIX and libquadmath build process use of
# LD_LIBRARY_PATH can break AIX bootstrap.
powerpc-*-aix* | rs6000-*-aix*)
@@ -552,6 +555,9 @@ case "${target}" in
cris-*-* | crisv32-*-* | mmix-*-*)
noconfigdirs="$noconfigdirs target-libsanitizer"
;;
+ powerpc-*-aix* | rs6000-*-aix*)
+ noconfigdirs="$noconfigdirs target-libsanitizer"
+ ;;
esac
# Disable libssp for some systems.
@@ -571,13 +577,6 @@ case "${target}" in
;;
esac
-# Disable libquadmath for some systems.
-case "${target}" in
- avr-*-*)
- noconfigdirs="$noconfigdirs target-libquadmath"
- ;;
-esac
-
# Disable libstdc++-v3 for some systems.
# Allow user to override this if they pass --enable-libstdc++-v3
if test "${ENABLE_LIBSTDCXX}" = "default" ; then