summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrooks Moses <brooks.moses@codesourcery.com>2007-03-02 00:28:09 +0000
committerBrooks Moses <brooks@gcc.gnu.org>2007-03-01 16:28:09 -0800
commit9c4d24932ed29249ebb8ba1a3cff0679b9d2f58a (patch)
tree70c260d66d8bf2a8a291e16f34defa090612c49d /configure.ac
parentbcc3d150be9a6665de62f6c7e8bda0f0d1d8b740 (diff)
downloadgcc-9c4d24932ed29249ebb8ba1a3cff0679b9d2f58a.tar.gz
configure.ac: Add "--with-pdfdir" configure option, which defines pdfdir variable.
* configure.ac: Add "--with-pdfdir" configure option, which defines pdfdir variable. * Makefile.def (target=fixincludes): Add install-pdf to missing targets. (recursive_targets): Add install-pdf target. (flags_to_pass): Add pdfdir. * Makefile.tpl: Add pdfdir handling, add do-install-pdf target. * configure: Regenerate * Makefile.in: Regenerate From-SVN: r122467
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09c1bef3573..16ff8d3ddf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2612,6 +2612,11 @@ AC_ARG_WITH(docdir,
[docdir="\${prefix}/${withval}"],
[docdir="\${datarootdir}/doc"])
+AC_ARG_WITH(pdfdir,
+[ --with-pdfdir Install pdf in this directory.],
+[pdfdir="\${prefix}/${withval}"],
+[pdfdir="\${docdir}"])
+
AC_ARG_WITH(htmldir,
[ --with-htmldir Install html in this directory.],
[htmldir="\${prefix}/${withval}"],
@@ -2619,6 +2624,7 @@ AC_ARG_WITH(htmldir,
AC_SUBST(datarootdir)
AC_SUBST(docdir)
+AC_SUBST(pdfdir)
AC_SUBST(htmldir)
AC_OUTPUT(Makefile)