summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2008-10-13 08:05:25 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2008-10-13 08:05:25 +0000
commitc214098d5f8e06c2fa554f7bf2311cc93321a074 (patch)
tree3ca4271029a8c1d19fafddd1c8f9df499e2abdb0 /configure.ac
parente4cdb4c6a9fe30297ea553e9724a836fd46fe331 (diff)
downloadgcc-c214098d5f8e06c2fa554f7bf2311cc93321a074.tar.gz
* configure.ac (MPFR check): Bump minimum version to 2.3.0 and
recommended version to 2.3.2. * configure: Regenerate. gcc: * builtins.c: Remove MPFR_VERSION_NUM(2,3,0) conditionals. * doc/install.texi: Bump recommended MPFR to 2.3.2. fortran: * simplify.c: Remove MPFR_VERSION_NUM(2,3,0) conditionals. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@141085 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index aa29d534ff5..bd6afe59a25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1267,11 +1267,11 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
if test x"$have_gmp" = xyes; then
saved_LIBS="$LIBS"
LIBS="$LIBS $gmplibs"
- dnl MPFR 2.2.1 is acceptable, but MPFR 2.3.0 is better.
+ dnl MPFR 2.3.0 is acceptable, but MPFR 2.3.2 is better.
AC_MSG_CHECKING([for correct version of mpfr.h])
AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
- #if MPFR_VERSION < MPFR_VERSION_NUM(2,2,1)
+ #if MPFR_VERSION < MPFR_VERSION_NUM(2,3,0)
choke me
#endif
mpfr_t n;
@@ -1284,7 +1284,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
mpfr_subnormalize (x, t, GMP_RNDN);
], [AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
- #if MPFR_VERSION < MPFR_VERSION_NUM(2,3,0)
+ #if MPFR_VERSION < MPFR_VERSION_NUM(2,3,2)
choke me
#endif
mpfr_t n; mpfr_init(n);
@@ -1295,7 +1295,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
CFLAGS="$saved_CFLAGS"
if test x$have_gmp != xyes; then
- AC_MSG_ERROR([Building GCC requires GMP 4.1+ and MPFR 2.3.0+.
+ AC_MSG_ERROR([Building GCC requires GMP 4.1+ and MPFR 2.3.2+.
Try the --with-gmp and/or --with-mpfr options to specify their locations.
Copies of these libraries' source code can be found at their respective
hosting sites as well as at ftp://gcc.gnu.org/pub/gcc/infrastructure/.