summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-05 14:10:07 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-05 14:10:07 +0000
commitf6be6a9658f76b62ade6d8ee67829aba87580062 (patch)
tree47648930adc7257564b04872b60f1324eab3d45e /configure.ac
parent03c2a028331cff77958aa9c35b04f6b14647b7d4 (diff)
downloadgcc-f6be6a9658f76b62ade6d8ee67829aba87580062.tar.gz
2007-09-05 Richard Guenther <rguenther@suse.de>
* configure.ac (--enable-stage1-checking): If neither --enable-checking nor --disable-checking is provided also turn on yes and types checking for stage1. * configure: Re-generate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@128131 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2486049cf18..57de10003ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2613,10 +2613,10 @@ AC_ARG_ENABLE(stage1-checking,
[ --enable-stage1-checking@<:@=all@:>@ choose additional checking for stage1
of the compiler],
[stage1_checking=--enable-checking=${enable_stage1_checking}],
-[if test "x$enable_checking" = xno; then
+[if test "x$enable_checking" = xno || test "x$enable_checking" = x; then
stage1_checking=--enable-checking=yes,types
else
- stage1_checking=--enable-checking=types${enable_checking+,}$enable_checking
+ stage1_checking=--enable-checking=$enable_checking,types
fi])
AC_SUBST(stage1_checking)